.Net 2 Concerns

Dec 7, 2010 at 10:11 PM

I have a client on a .Net 2 platform, and am unable to upgrade to .Net 3 due to issues with backwards compatibility.  I have attempted to get this to work, yet continue to run into this error:

"Could not load file or assembly 'System.Runtime.Serialization, Version=3.0.0.0, ..."

I am assuming that this wrapper requires .Net 3 to operate.  Have you any idea how this might be able to work in .Net 2?

Coordinator
Dec 8, 2010 at 7:41 AM

Hi. It can't be compiled under .NET 2.0 because it doesn't support WCF.

Did U try http://perceptivemcapi.codeplex.com/ ?

Dec 8, 2010 at 3:32 PM

Thanks for the reply!  I took a look at the Perceptive MCApi, but it too required .Net 3 (according to the documentation) so I passed.  I ended up taking the deprecated MailChimp MC.NET wrapper and re-wrote the parts I needed to work with version 1.3 of the API.

I really like what you've done though!  I have a bunch of clients on .Net 3 platforms, and will play around with your API Wrapper there.

Keep up the good work!


--
John Richardson
Swank Internet Business Solutions LLC